
Real 3D programs have several advantages over After
Effects: For example, their objects have real depth, and

the texturing and lighting options are far more advanced.
However, this power often comes with a significant speed
penalty, which can be a problem when accommodating client
changes. After Effects is also the better tool in which to refine
the final look of your 3D worlds. Offloading portions of the
work from your 3D program to After Effects will save time
while giving you more power and flexibility – but it requires
some effort to set up. 
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Techniques to get 
more information 
from your 3D program
into After Effects.

Example Project
Explore the 38-Example
Project.aep file as you read this
chapter; references to [Ex.##]
refer to specific compositions
within the project file. 
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3D Channel Effects
Bonus Chapter 38B on this
book’s DVD covers the special
3D Channel effects such as
Depth of Field and Fog 3D, 
as well as how to replicate 
their results with 3D programs
not directly supported by 
these plug-ins.

FA C T O I D

In this chapter, we will give advice on how to successfully integrate
your 3D program with After Effects. We will then work through a pair of
case studies: Adding 2D video to the face of a 3D object, and integrating
lights and shadows between After Effects and your 3D render. The DVD
also contains a bonus chapter which covers the 3D Effects that can
access additional information saved with some 3D renders such as the Z
buffer (how far objects are away from the camera).

Unfortunately, there is no one universal file format to bring informa-
tion from a 3D application into After Effects. In our case studies, we are
going to focus on using Maxon Cinema 4D as it currently has the tight-
est integration with After Effects, plus is the 3D program we personally
use. However, many of the concepts we’ll be covering are universal and
can be applied to other programs as well. We will also include some
 specific advice for programs such as Autodesk Maya and 3ds Max.

Tight integration makes it easier to add video and other layers to 3D environments
in After Effects. Video courtesy Creative License; textures courtesy Artbeats.

Excerpt from Creating Motion Graphics with After Effects, 4th Edition.
Copyright © 2008 Trish and Chris Meyer.

No part of this publication may be reproduced or distributed in any form or by any means.

Focal Press, ISBN: 978-0-240-81010-2



3D Advice
The next few sections include topics to keep in mind as you work on a
project that will flow from a 3D program to After Effects. This includes
getting the camera move across, lining up world coordinates between
the two programs, and creating mattes so that select objects in the 3D
world will appear to pass in front of layers added in After Effects.

The Camera Move
A typical workflow will include finalizing your camera move in the 3D
program, rendering the 3D scene, then bringing the camera move and
render into After Effects. Your render will be a 2D layer in After Effects,
as it already has the camera move calculated into it; you can optionally
enhance the render using After Effects’ tools. You can then add new 3D
layers on top of this render in After Effects, using the camera data you
moved across. For example, you can add text, video, and other objects to
your scene in After Effects without having to go back into your 3D pro-
gram for another potentially lengthy re-render. 

It is a really, really good idea to finalize the camera move before bring-
ing it into After Effects. Changing the camera move means having to re-
render the 3D scene as well as replace the camera move in After Effects.
Do a few rough renders and get the client to sign off on the general idea
and movement before putting in too much work.

The way you move camera data from
a 3D application into After Effects varies
from program to program. Here are
some of the more common options:

� Export your project to the .ma – Maya
ASCII – format. After Effects can then
import this project through its normal
File > Import menu command; it will
extract the camera movement from this
file along with the movement of any null
objects that explicitly have the word
“NULL” or “null” in their name. You can
practice this with the file 38_Chapter
Sources > Maya > Maya_camera.ma.
The result – with new video composited
into the scene – is demonstrated in this
chapter’s example project in the comp
[Ex.01-Maya Import].

� Embed the camera move in a .rla or
.rpf frame sequence when you render.
Bring this sequence into an After Effects
comp, select it, and use Animation >
Keyframe Assistant > RPF Camera Import.
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Maya Camera Import Bug
There is a known bug in the
initial release of After Effects
CS3 where some Maya .ma
projects may import at the
wrong size. For example,
Maya_camera.ma included 
on this book’s disc imports 
as 540x486 pixels, when it
should be 320x240.

G O T C H A

38 // Integrating with 3D Applications

Programs such as 3ds Max can embed their camera move in an RPF file
sequence during their render. After Effects can extract this data to create 
a matching camera of its own.

Maya ASCII (.ma) project files may be imported directly into After Effects. 
The result is a comp with the Maya camera, any null object with “null” in its
name, parenting chains including cameras and nulls, and their animation.

Motion Blur
If you rendered your 3D scene
with motion blur enabled, you
should also enable motion blur
for the 3D layers you add in
After Effects. Don’t forget to
match the blur’s shutter angle
you used in your 3D program.

T I P



After Effects will then create its own camera
with the same movement. You can practice
this with the comp [Ex.02*starter]; the result
– along with some additional compositing
tricks using 3D Effects – is demonstrated in
[Ex.02_final].

� Cinema 4D has the ability to save an .aec
project file which contains the camera move
and much, much more (which we will dis-
cuss in detail in the upcoming case studies).
After Effects can then import the .aec file
with a Maxon-supplied plug-in. 

� If the functionality you need isn’t built
into your 3d program of choice, you may be
able to write a spreadsheet or script that con-
verts keyframe data from your 3D program
into After Effects keyframe data, and paste
that into a new camera created in After Effects;
see the Camera Data Translation side bar for
leads on others who have already.

� Worst case, create an object in your 3D
world in the same location as layers you
would like to add in After Effects, with obvi-
ous markers in its corners. Make a separate
render pass of this object, and use Motion
Tracking in After Effects to corner pin your
new layer into the position and perspective
you had in mind. This was demonstrated in
Chapter 29’s [Ex.05]; another example is
included in this chapter’s [Ex.03].

Sometimes, your imported
camera move will not appear to
match the motion in your 3D ren-
der. The most common problem is
that the Angle of View for the After
Effects camera is wrong. Verify the
value for this parameter (also
known as Field of View) in your 3D
program, and enter this value
manually in the Camera Settings
dialog in After Effects. 

Some 3D programs also do not take into account any curves you may
have applied to the camera’s path or speed. Therefore, you will often
need to “bake” the camera move in the 3D program to create a keyframe
for every frame of your timeline before exporting its move. For example,
in Maya use Edit > Keys > Bake Simulation in Maya.
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If there is no way to import the
camera data from your 3D program
into After Effects, you can create a 
3D model with dots to track in After
Effects (A), and corner pin a new layer
in After Effects to their location (B).
3D renders courtesy Reject Barn.

Camera Data Translation
Several third parties have developed ways to get camera
data from 3D programs into After Effects:

� Helge Mathee (www.mindthink.de) has created a
Softimage|XSI script that can save camera and light data
as an .aec file, which can then be imported using Maxon’s
Cinema 4D import plug-in.

� The TransMotion Utilities Pack (www.ats-3d.com) 
gives users of older versions of LightWave several options
beyond .rpf files to get camera and other data from
LightWave to After Effects.

Less common is being able to transfer AE’s camera 
data back to a 3D program. Exceptions include:

� Paul Tuersley of AE Enhancers (www.aenhancers.com)
has written a script to get an After Effects camera move
back into Cinema 4D.

� MAX2AE from Boomer Labs (www.boomerlabs.com)
allows you to import a scene from After Effects into 
3ds Max 6 or later. It also provides a nice alternative 
to importing Max scenes into After Effects, including 
support for lights and “helper planes.” 

� Likewise, 3DMation’s MoCon (www.3dmation.com) is an
inexpensive collection of scripts to transfer 3D motion to
and from After Effects, Maya, Nuke, SynthEyes and Electric
Image, including going from After Effects into Maya.

Integrating with 3D Applications // 38
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Multipass Rendering

There are other ways to combine 3D programs and
After Effects into an overall workflow. For example, 
as an alternative to creating object buffers, some 
like to render 3D objects (such as logos) as individual
elements with alpha channels, then composite them
in After Effects. 

Another related trick is called Channel Lighting, in
which you render two passes from your 3D program:
one with the normal materials applied to your objects
and 100% ambient light, and a second with a plain
white material applied and each light given a color 
of red, green, or blue. The contributions 
of these colored lights can then be
isolated, recolored, and blended
inside After Effects without having 
to return to your 3D program. 
The Walker Effects plug-ins make 
this easy, including docu men tation
on how to pull it off (visit them at
www.walkereffects.com and look
under Tour > Channel Lighting).

Many 3D artists like to render 
individual aspects of their scene – 
for instance, diffuse color, specular
highlights, shadows, reflections – 
as independent “passes” to be 
re-blended in After Effects using a combination 
of alpha channel and blending modes (Multiply for
shadows, Add or Screen for reflections and other
color passes). This results in a high degree of control,
such as being able to change the strength of a 
reflection map or darkness of a shadow without
having to go back into the original 3D project.

Most 3D programs require you to set up and
render each of these passes individually. If you are
trying to isolate specific properties perhaps on just 
a few objects in your scene, you can tweak your
project file as needed between renders. If you know
you will be tweaking a multipass render later in 
After Effects, it is a good idea to “overdo” properties
such as shadow darkness, specular highlights, and
reflections so that you have some latitude to increase

or decrease the opacity of these layers (and therefore,
their contribution to the final composite) without
having to render the scene over from scratch.

In the [Ex.05] folder, we have included a render
from Cinema 4D that demonstrates some of this
power. Cinema is the current king of integration with
After Effects: It has a dedicated Multi-Pass render
section where you can set which properties will be
rendered to their own files simultaneously with the
main render, and it will create an After Effects project
with all of these properties already arranged in a
composition using the correct modes. Have fun
playing with the opacities of the various layers. 
We’ve increased the shadow darkness and amount 
of reflection in the original Cinema project to give
you a wider value range to play with.

Multipass rendering gives you the power to adjust the strength of shadows,
highlights, and reflections after the fact. Experiment for yourself with
[Ex.05]; the original Cinema project is C4D videowall_multipass.c4d.



Study #2: Shadow Trickery
One of the more challenging areas of integrating a 3D render with After
Effects objects is handling the shadows. You’d like for any new objects
you add in After Effects to cast 3D shadows onto objects in the original
3D render. However, the 3D render must be imported as a 2D layer, and
3D layers cannot cast 3D shadows onto 2D layers. Your choices? Do with-
out, fake it with an ordinary 2D Drop Shadow effect, or do a little extra
work: Add 3D layers in After Effects to mimic objects in the original 3D
scene which can then catch the 3D shadows. Let’s try this last approach.

Open Ex.06 > Cinema 4D Composition; it contains a
scene that will look familiar to those who made it to the end
of our introductory book, After Effects Apprentice. Here are
the steps needed to make it shadow-friendly in After Effects:

Step 1: The wall, floor, and table are candidates to catch
shadows, so we need to know where to place their stand-ins
in After Effects. We made a note of their sizes and where
their faces were located in 3D space. In Cinema, we set their
anchors to the center of their faces, then applied External
Compositing tags (discussed in the previous section) to
these models. This resulted in null objects being created for
them in the corresponding .aec file.

Step 2: To crop our stand-in layers, we needed to render
mattes that corresponded to just the visible portions of the
faces of these models. In Cinema, we applied Compositing
tags to these objects and assigned them to individual Object
Buffers. We did the same for the Harlequin title so we could
place layers in After Effects “between” the title and the wall.

Step 3: Once these 3D passes were rendered, we imported them along
with the camera and light data into After Effects. We’ve already done this
for you; if you have the Cinema import plug-in installed, you can do this
yourself: Import 38_Chapter Sources > shadow study > AEA Room.aec.

Open the comp Ex.06 > CINEMA 4D Composition and note the three
null objects back wall, floor, and tabletop. You need to replace these
with solids. Here are the steps for one; the others are done the same way:

Step 4: The face of the back wall model piece is roughly 3110 wide ×
1050 high in “world units” in Cinema, so create a Layer > New > Solid of
this size, using square pixels and colored white. Name it “wall shadow”
and click OK.

Step 5: Next, you need to move this shadow catcher into the same posi-
tion as the wall. To do this, enable the 3D Layer switch for wall shadow.
Select back wall (the null object created by Cinema) and type P followed
by Shift+R to reveal its Position and Rotation parameters. Copy these,
and paste them to wall shadow.
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Follow Along
For those with Cinema 4D, our
original Cinema project file for
Study #2 is on this book’s disc in
38_Chapter Sources > Cinema
4D Projects > C4D AEA room.

T I P

More on Multipass
Check out dvGarage’s Multi-Pass
Render Lab for a set of in-depth
training materials on enhancing
renders using a multipass
approach (visit dvgarage.com
and look under Products > 
3D Development).

T I P

Steps 1–2: We added Compositing 
and External Compositing tags to the
tabletop, floor, and back wall models
to generate null objects and mattes for
them in After Effects. We also added 
a Compositing tag to generate a 
matte for the Harlequin title model.



Step 6: We want this layer to receive our new shad-
ows, but not otherwise be affected by lights in this
scene. With wall shadow still selected, type AA to
reveal its Material Options in the Timeline. Leave
Casts Shadows = Off and Accepts Shadows = On (their
defaults), but set Accepts Lights to Off.

Step 7: The shadow catcher needs to be matted to
match the visible portions of the 3D wall. In the
Special Passes folder, locate AEA Room_object _2.mov
and drag it into your comp just above wall shadow.
Reveal the Modes column (F4) and set the TrkMat
popup for wall shadow to Luma Matte.

Step 8: To composite just the dark shadows – not
the wall’s white color – onto the back wall, set the
Mode popup for wall shadow to Multiply.

Step 9: Add a layer to the scene in After Effects, enable its 3D switch,
and enable Cast Shadows. Its shadow will appear on the back wall of the
original 3D render. Feel free to tweak the color, intensity, and shadow
darkness of the lights originally created in Cinema to work best for your
new layers in After Effects, but keep their positions if you want the new
shadows to match the original render.

If you want to cast shadows on the floor or table, repeat steps 4–9
above and use these parameters:

� The floor is about 3100×2050 pixels in size and uses Object Buffer 3.
You will need to set its X Orientation to 270° to flip it down horizontally.

� The tabletop is approximately 512×512 pixels and uses Object Buffer
4. Due to differences in how the object was created in Cinema, disable
keyframing for the three Rotation values, zero out Y Rotation and instead
set Z Rotation to –17°, and set X Orientation to 270° to flip it down.

The comp [Ex.06-Shadow Trickery_final] has these three shadow
catcher layers set up, with some new objects casting shadows. Adding 3D
elements from After Effects into a fully rendered 3D world creates an
interesting hybrid look in its own right, you can also gain substantial
flexibility from distributing your workflow between the programs.

611

Integrating with 3D Applications // 38

Blending modes: Chapter 9.

Track mattes: Chapter 11.

3D space, cameras, and lighting: Chapters 13–15.

Null objects and parenting: Chapter 16.

Time stretching: Chapter 27.

Corner pin motion tracking: Chapter 29.

Expressions: Chapter 35.

Importing files and the Interpret Footage dialog:
Chapter 36.

Pixel aspect ratios and frame rates: Chapter 39.

C O N N E C T

A

Steps 4–8: Create a white solid the size of the back wall, put it in the same position (A), set its Material Options > Accepts Lights
to Off (B), crop it by its corresponding matte (C), and set its Mode to Multiply (D) so it blends into the original 3D render.

B C D

After you’re done, new 3D layers added
in After Effects can cast shadows on the
wall, floor, and table. If you have Cinema
and are up for a challenge, use our
projects to also create a shadow catcher
for the Harlequin title…


